Error creating a new App

Hello, I’m a trial user moving on from LightSwitch. Created my first project, but didn’t get far. Here’s the data setup:

Well, guess there’s no pasting or uploading of graphics. So, data source is ms sql server, with windows auth, encrypt connection unchecked, and trust server cert checked. I click “infer schema” and immediately get an error that pops up: “A Javascript error occurred in the main process” “uncaught exception: Error: spawn dontnet ENOENT at exports._errnoException (util.js: 1022:11)”…, and then there’s a bunch of other stuff - again wish I could paste the error dialog. Looked through the windows event logs, but it didn’t land in there.

So, if I click the OK button, it disappears and displays the “inferring schema” where it spins forever and never ends. This exact same environment is what I use for developing my Lightswitch apps, so I don’t know what could cause this. Thanks!

Hi @SloSuenos,

Sorry about the error! Can you post more info about your setup? Windows and .NET Core versions, SQL Server version, etc.

Best Regards,
Vladimir

Hi @SloSuenos,

Could you please answer the following questions?

  1. What version of .NET Core do you have installed? You can try running dotnet --version in command prompt to check this out.
  2. Can you verify that the following files exist in your Radzen installation? Those are required to connect to SQL server.

Looking forward to hearing from you!

Hi @SloSuenos,

We have released a new version of Radzen which addresses a few compatibility issues that sound similar to the one being discussed here. You should get it via autoupdate. Could you please try and see if the problem is addressed?

Hello, I replied to your email queries, but then realized that they were going to 'noreply@radzen.com'. Pasted everything to the below:

Opening it this morning, I didn't notice any updating. Maybe it did it yesterday and I didn't notice? My version is 2.1.0. The issue still occurs. Here's some more info:

image

Not sure if you're actually receiving the images I pasted above.

Workstation is Windows 10 x64, SQL Server is Windows 2012 running SQL 2012 (11.0.6251.0). Both are in a Windows Domain environment. Enclosed srb.zip is msinfo output.....nevermind. New user cannot upload attachments.

Is there a way to force the update, or should I download from your website?

Thanks for the help,
Stephen Barash

Okay, New user can only post one image, so cutting out all the other images except the error msg.

I created a new database, empty with no tables. Same error. Tried the new db with create sample schema - same error. Tried new db with sql server auth - same error.

The error dialog pops up immediately. So fast that I don’t think it even tries to touch the sql server before erroring.

Thanks again,
Stephen

Just installed .NET Core 2.1 SDK - Same error…

Is this with the latest Radzen version (v2.1.1)? Also does running dotnet --version right now show 2.1 after installing it?

No, as I stated - I’m at 2.1.0

From what you’ve stated, it should auto-update, but it doesn’t. How do I get it?

After installing the .net core sdk 2.1, dotnet --version shows: 2.1.302

I’ll try a reboot after the .net core installation and see if that helps…

Okay, now we’re getting somewhere. So, when I created my first project, I did not check the ‘server side project (.Net core)’ checkbox. When I selected SQL Server as a new datasource, I got an error message saying that I needed to make this .net core project, go to the application settings and select 'server side project (.net core). So, that’s what I did, and then when trying to set sql as a new datasource in infer the schema, got all the errors.

I decided to try a new project, and this time selected the .net core checkbox at the start. To my surprise, I was also asked to select C# or VB.net. The language selection was not asked in the application settings of my prior test project.

This new project works! I was able to infer the sql db schema without error. We’re good, case closed - and I think you have a little bug to fix.

Thanks for the great support!

Stephen

1 Like

Thanks for the steps Stephen! We will fix this immediately.

Best Regards,
Vladimir