Error adding MSGraph as ODATA Source

Version: 2.50.7
I tried to add MSGraph as in your blog article

After adding it the page preview looks as follows (Empty Page):

I genearted a project in 2.50.0 with MSGraph as datasource. This worked.
Opening in it 2.50.7 endend in the same preview as above

In Both Version you can not run the generated project.
Error: CS0101: Der Namespace "DscApps.Models.MsGraph" enthält bereits eine Definition für "Modality".
It does not matter what entities you select.

Both errors persit after deleting the datasource

Antother issue is that editing the datasorce alwas shows the default setting, not what hav been selected

Here is the same application on my end using latest Radzen:

Tried it on 3 different machines with different Version of the SDK.

In the end all results in the same error.

The best I get was on a fresh install the preview works after adding the MSGraph data source. But after closing and reopening the app same error

The preview looks like the picture above, app cannot be run because of the Error: CS0101: Der Namespace "DscApps.Models.MsGraph" enthält bereits eine Definition für "Modality".

Problem 1: the model is always generated with the default settings, not with the selected entities.

Problem 2: Deleting the data source does not delete it complete. Close App delete manually. Then the preview is working again

We were able to reproduce the problem. It seems that Microsoft changed the meta - we will do our best to provide fix before the end of this week.

With the actual version ist working.

But there seems to be a spelling problem with the user object
If you set a property to the result of GetUsers the type is set to: Radzen.ODataServiceResult
With results in the error Namespacename "user" not found

After change to Radzen.ODataServiceResult running the app is passible.
But the property is not usable, because then you get other errors as result of different spellings

I'm not sure I understand where is the spelling problem

i put the getusers in the load function of a Page:

The data tye is set to:

users in lowercase!
the app can only be run if you change this to Users (U uppercase)

If you try to bind a data grid to this property -> error converting to Radzen.Page.user

Not sure how you've got this. Here is what will be created using DataGrid new data wizard:

Created new app -> added MSGraph -> add DataGrid Page per Wizard.
Page is working, but displays no data (maybe missing rights)

Added second page with the getme function:

Result App does not start: error CS0029: Der Typ "Microsoft.Graph.User" kann nicht implizit in "Mytest3.Pages.User" konvertiert werden

Delete DataGrid page -> App starts

Added Label with value ${MyData.displayName} -> Page not loadable, error: Unhandled exception rendering component: Object reference not set to an instance of an object

Writing the values direct in properties is working:

You should use the full type name with namespace since you have a page with same class name.