DataGrid Trim string

Hi, i have problem with visualization string in datagrid
When i set string with lot space as a result i have trimmed string



Is it possible to disable trim in datagrid

Not sure why a string might be trimmed however you can define your own Template for the column and you will get what you’ve declared.

This is how HTML treats whitespace by default - it only displays a single one. You can use the white-space CSS attribute to control that:

<RadzenDataGridColumn ...>
    <Template Context="data">
       <span style="white-space: pre">@data.Property</span>

As an option it will work, but what if there are 500+ grids in the project and 10+ columns in each, if there is some universal solution for this problem?

I tried to do it with css but it didn't work very well


This is the only solution that we are aware of. To be honest it seems to work as expected to me - there is visible whitespace. Probably the column width needs to change for the other columns though.

You can probably try the other options for the white-space and see if something else yields to better display.