Cannot invoke simple custom method

New to the IDE, trying some basic concepts.

Something I'm struggling with is calling my custom methods from <page-name>.razor.cs as detailed on page Invoke method (Blazor)

Brand new project, create single page. Open the .cs file in VS2019. Add the 'Sum' method and attempt to invoke it. As pictured below, my method doesn't show. I've reloaded, refreshed edited in Notepad++ and nothing exposes it.

What am I doing wrong?

Hello dam0,
What is the name of the page in which you need to call the custom method ?

In the screen shot it was titled P1.

I've just installed Radzen on my main PC (I was using my laptop last night) and the same occurs. Please see video below. This is a brand new install of Radzen, using VS2019.

VDO not payable. Pls share a fresh link

how strange.

Uploaded to youtube now.

try running the application from radzen and then check.

Ah, ok. So it needs building in Radzen first before it will expose the methods.

Thank you, that worked.

Hi, sorry this issue for me still isn't resolved.

It turns out my methods are only exposed in Radzen if Radzen application is restarted. Any method I create in VS doesn't get shown in Radzen until I close and start the Radzen UI again. Obviously when I tested and advised it worked as above, I had closed and reopened Radzen UI so it gave the appearance of working.

I assume this isn't normal. I have created example video below showing this.
It is based on the CRM tutorial. MonthlyStats method is shown only because I restarted Radzen before the video, as you'll see the 'TestMethod' method only is shown following restart of the Radzen UI.

I am not sure why this is happening. I have never faced this issue.

Could anyone from the Radzen team comment?

It seems something prevents Radzen from detecting that a file has changed. We are not sure what though and cannot reproduce such a problem locally.


I've replicated it on two workstations. I can confirm Radzen triggers a rebuild once I save in VS2019, log in Radzen as below.

dotnet: watch : 
dotnet: Exited
watch : File changed: E:\Development Project Root\IotWebPublic\server\Pages\Feedbacks.razor.cs
dotnet: watch : Started

I've returned back to Radzen to see if the issue is resolved in newer versions.

Radzen still does not recognise the file has changed when updated by either VS2019 or VS2022. I'm also using an entirely new computer since I last encountered this.

The .cs file when changed updates the timestamp and file size of the file.

The workaround is to have notepad++ open, let it detect the change, enter a carriage return in the file in notepad++, save and then Radzen will detect the file change.

Any thoughts?