Bug with the Register Form

There is a bug with the Register Form. Clicking on the Register button does nothing.

I looked through the code but unfortunately couldn't find the issue. I know I had it working in an earlier demo that I had created. I ran the early demo using Visual Studio and the Register Form worked fine. Then I opened the demo in Radzen and ran from there. This time it did not run. Looks like the new code generated via Radzen has an issue. Tried running the demo again using Visual Studio and now it doesn't work.

Looks like some issue in the generated code.

Here is how it looks the Register button code usually when email confirmation is enabled:

I was referring to running the App in the browser. Not the design view in Radzen.

This can happen if there is no code associated with the event. Check my reply again.

I'm referring to Register button in the Register Application User page. Here's the screens from this:

image

I just created a clean App using the Sample Database generated through Radzen and ran the Application. Clicking on the Register button does nothing

image

Sorry, here's the screen capture

Was using v2.59.1. Tried now on 2.59.2. Still an issue.

Functionality to register a new user is broken.

Confirmed! The problem is in Radzen.Blazor and as soon as we have fix we will publish new version - you will need to update the reference in your project. I'll post here when we are ready.

Thank you.

I compared the code for the project that was working against that wasn't working and the generated code wasn't different.

I uninstalled Radzen.Blazor 3.2.6 and installed 3.1.10 and then it worked fine. Looks like you've found the cause.

Appreciate you looking into this.

Register Form works with Radzen.Blazor 3.2.3 but not any version after that up to 3.2.6

Update of both Radzen Blazor and Radzen will be released early next week.