Bug: UI lockup

I can lockup the UI by creating two fields with the same identifier. When the cursor leaves the second field, an error message will popup. After confirming the error-dialog, most of the ui is unusable until radzen is fully closed and reopened.

For some reason we cannot reproduce the lockup. After closing the first message box Radzen remains responsive as it is supposed to. Here is how my experience looks like

Does this happen in any page and component? Could be somehow related to the specific page.

My example-gif was made on a totally different page then where I found that bug initially.
I tried it with labels and textboxes, same result.
I tried it with 2 new projects too (Blazor and Angular, no Datasource, new page, duplicate Header, give both the same name -> lockup), same result.

Up-to-date Windows 10x64 (Build 18363.836)
Radzen 2.47.4
Any other components/versions I could check for?

Managed to reproduce it and will investigate further.

Seems to be this issue. I discovered that the UI unlocks after some time (one or two minutes?). Nevertheless we will address that with the next Radzen release. Thanks for reporting this bug!