Application hangs after deployed

You where right. Now it works like you said but not getting data.
Now I get these two errors:

Just a moment. Forgot to change db. Deploying again ...

Now it is working on my dev machine. Going to try the server.

The application is also working on the server but only with localhost:5000 after running dotnet server.dll in command prompt.
I cannot access it from the binding on another machine.
So that must be a different case?

You need to now host the application in IIS. Running with dotnet server.dll is only for troubleshooting to see that it works correctly.

I have been doing that all the time :slight_smile:

When I browse the website I get this result.
And in the directory of the application I get a logfile starting with radzen_xxx and it is empty.
Any clue?

This IIS error usually happens when IIS can't find the dotnet executagle to run the application. Check if the PATH variable for all accounts (not just the current user) contains the path of the .NET core installation. Normally the .NET Core installer does set the PATH correctly but sometimes it fails to do so for all accounts (including the one which IIS runs with). This should be in the System variables:

A system restart may be needed after making any changes.

I restarted the server and now it works like a charm.
This has been something.

Thanks very much for your help.