Application hangs after deployed

I built my first application and it runs as expected in Radzen dev tool.
I have deployed to a zip file and install it on my server.
I created a new website under Sites (not under Default web site as in the help doc.)
I add wwwroot as the root folder.
I also added binding to
But when I call the new website from a browser I get the start page but no data and the cursor runs all the time. And the url is strange because it is has gotten the startup page included so it is:
I also get error when I open the debug page in Chrome:
VM4859:1 GET$top=10&$skip=0&$count=true&$expand=NetorkaEmployee 404 (Not Found)
It would be nice to hear from you soon.

Most probably the base href is wrong - please make sure base href is set to / if the website is in the root.

Just to extend @enchev 's response - the base href is set from the Deploy to IIS screen in Radzen and by default is set to the name of the application. When you deploy to its own domain you should set it to /.

I have also tried that but get the same result.
Now I am using your application (RentCar example) to deploy a zip file. The application works fine on my dev machine but when I have deployed a zip file I get two errors (see image attached).

Can you post the Deploy to ZIP settings and how you deployed the app to IIS?

I am not sure what you are asking for but there are not a lot of settings in the deploy process. Here is a screenshot of deploy to zip if that is what you are asking for:

Thanks. Can you post also how/where the app is deployed to IIS?

I extract the zip file to a folder on my server (c:\websites\RentCar
I add a new website (RentCar) under Sites in IIS and point to wwwroot in the folder RentCar.
My server is Windows 10 (not Windows server).
I have installed dot.Net core privew8 like I have on my dev machine.
I am running 30 websites on this machine without problem.
If I am not giving you the right info please be more specific about what you want so I can help out here :slight_smile:

In my opinion you have deployed the application to a virtual folder and in this case the base href should be the virtual folder name (/rentacar). When you set / for base href the application should be deployed to the IIS root.

This is probably the issue. You should point the the IIS site to the Rentacar directory (the parent of wwwroot). The wwwroot directory contains only the static assets (JavaScript, CSS) whereas the parent directory is the published .NET core application.

This is giving me the error 500 and I thougt because the Index.html file was under wwwroot I should point to it.
So now I am getting error 500. Is it possible there is a log which can point out the error?

The log file should be available in the directory itself (unless the application failed to start). You can try manually running the app on the server to see the error. Open command prompt, go to the application directory and run dotnet server.dll. It should either run or throw an error.

Does this say anything?

This is what happens on my dev machine. But I am still getting error 500 there (on me dev iis machine).

This error means that .NET Core 2.2 isn't installed on the server. You need to install this

Do you see any exceptions in the log file or in the command prompt when you request the localhost:5000 in your browser? Also make sure the connection string is correct. Sometimes the current user may not have access to MS SQL server and you may need to use username/password security.

I have installed what you sent me. Now things look different but still error when browsing:

And this is from cmd.
The db user has db owner privs for the db.

And this is from cmd

But still errors :frowning:

Does the same application run on the same machine from Radzen? Is there any exception when you run the app from command prompt and browse localhost:5000? Let's first deal with that problem - the other is something IIS/.NET Core related.

This is what happens on my local machine (Win10) where Radzen dev works fine.

This application has been deployed with base href set to "/rentacar" and will not work from command line - as you see all requested files lead to 404 error.
Run deploy to zip with Base href set to "/". Then unzip the file, run dotnet server.dll and let me know if that works. You should at least see the application and a DataGrid that tries to load data. If that fails the exception should be loaded in the console.